Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Θέματα που αφορούν την δρομολόγηση και την διευθυνσιοδότηση του δικτύου
User avatar
grigoris
AMD Athlon
Posts: 951
Joined: Mon Mar 12, 2007 12:25 pm
PWMN Wind ID: 74
Contact:

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by grigoris »

ianos wrote:Μια παρατήρηση,

Όπου υπάρχουν κόμβοι που χρησιμοποιούν και τα 2 προτόκολλα γιατί κάποια peers δεν έχουν σηκώσει bgp θα πρέπει να κανουν redistrubute τα routes του ενός προτοκόλου στο άλλο ώστε να μη χάνετε το connectivity.

Ianos
Δε θα πρεπε να υπαρχουν κομβοι που χρησιμοποιουν και τα 2 πρωτοκολλα. Και αυτο με τα redistributes ειναι γενικως αρκετα επικινδυνο και θα επρεπε να χρησιμοποιουνται με filters

User avatar
Itmy
AMD Athlon
Posts: 893
Joined: Thu Mar 08, 2007 12:17 am
PWMN Wind ID: 108
Location: Itmy Territory
Contact:

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by Itmy »

Πρόσθεσα στο BGP Tutorial του wiki (http://www.pwmn.net/wiki/index.php?title=BGP) και κάποιες σύντομες οδηγίες για bgp σε open-wrt: http://www.pwmn.net/wiki/index.php?titl ... 8quagga.29
Death to all Fanatics

User avatar
alfadeck
Intel 8088
Posts: 48
Joined: Tue May 27, 2008 2:25 pm
PWMN Wind ID: 325
Location: Αγρινιο

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by alfadeck »

Χαιρετε

Καλο ειναι να διαλεξετε το AS-Dot φορματ δηλαδη ας μπαινει ολοκληρη η ΙΡ σας στο AS. Πιθανον να βολευει καλυτερα.
Επίσης επειδη παιδια εχετε αρχισει να παιζετε κεντρικο ρολο για τα γειτονικα δικτυα, καλο ειναι να θεσπιστε κανονες για ολους. Αρα προσπαθηστε σε καθε προσπαθεια να εφαρμοσετε κανονες και για τους γειτονες.

ΟΚ μπορει με το WIMES (αν και εχουμε πει με τα παιδια να λεμε wait-net πλεον) να εχετε 2 λινκς.
Δεν απαιτειται να γυρισει ολο το δικτυο σας σε bgp απλα οι κομβοι που συνδεονται να παιζουν παραλληλα bgp και να ρολαρουν τις διαδρομες και στους αλλους. Ισως πιο επιπονο αλλα εφικτο.

Τεσπα ενημερωστε και για Αγρινιο - Μεσολογγι να βοηθησουμε την κατασταση και παραλληλα να στηθουν ως πρεπει τα BGP.
Αγρινιο - alfadeck (#1143)
--------------------

User avatar
neoplan
Pentium IV
Posts: 1058
Joined: Mon Oct 08, 2007 10:55 pm
PWMN Wind ID: 188

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by neoplan »

Την αλλαγή την κάναμε γιατί είχαμε προβλήματα με το ospf και όχι για να έχουμε δυο διαδρομές με το wait-net. Τα προβλήματα αυτά έχουν λυθεί και έχουν φύγει και τα άπειρα static routes με τις υπόλοιπες κοινότητες (που χάναμε τη μπάλα).
Η συζήτηση ηταν να μπει όλη η ip ως AS αλλά δεν υποστήριζαν όλα τα router 32bit AS οπότε αρκεστήκαμε στα 16bit.
Είμαστε σε συνεννόηση με το awmn για να ρυθμίσουμε ένα πανελλαδικό σύστημα AS αλλά αυτό αργεί ακόμα.
Το pwmn τώρα χρησιμοποιεί AS: 60000-60999 και 63000-63999
Το wait απ'ότι βλέπω έχει για AS ~200-300. Αν θέλετε βάλτε κάποιο range κοντά σε εμάς πχ: 64000-64999
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn

xhaos
386
Posts: 225
Joined: Sun Nov 18, 2007 3:17 pm
PWMN Wind ID: 484
Contact:

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by xhaos »

έρχεται και τρίτο Link
viewtopic.php?f=4&t=1401&start=30#p13487

User avatar
alfadeck
Intel 8088
Posts: 48
Joined: Tue May 27, 2008 2:25 pm
PWMN Wind ID: 325
Location: Αγρινιο

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by alfadeck »

neoplan wrote: Η συζήτηση ηταν να μπει όλη η ip ως AS αλλά δεν υποστήριζαν όλα τα router 32bit AS οπότε αρκεστήκαμε στα 16bit.
Είμαστε σε συνεννόηση με το awmn για να ρυθμίσουμε ένα πανελλαδικό σύστημα AS αλλά αυτό αργεί ακόμα.
Το pwmn τώρα χρησιμοποιεί AS: 60000-60999 και 63000-63999
Το wait απ'ότι βλέπω έχει για AS ~200-300. Αν θέλετε βάλτε κάποιο range κοντά σε εμάς πχ: 64000-64999
OK θα το πραξουμε. Τασο Βασιλη εσεις που ειστε Μεσολογγι δωστε το εναυσμα να ακολουθησουμε.
(Τασο τις βασεις για τον ιστο στα Ελληνικα!)
Αγρινιο - alfadeck (#1143)
--------------------

tsatasos
Intel 80286
Posts: 128
Joined: Mon Oct 18, 2010 3:56 pm
PWMN Wind ID: 724
Location: Άνω Γλυφάδα - Μεσολόγγι

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by tsatasos »

Θα έρθω το επόμενο ΣΚ Σπύρο για 4 μέρες (14 με 17) και θα τις φέρω.
Κανόνισέ το για τότε ρε συ που θα κάτσω αρκετά, γιατί μετά δε ξέρω πότε θα ξανάρθω.

User avatar
freelan
386
Posts: 195
Joined: Fri Jan 30, 2009 9:25 pm
PWMN Wind ID: 447

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by freelan »

Επειδη με το bgp routing γινεται λιγο χαμος απο θεμα ρυθμισεων προτεινω να χρησιμοποιήσουμε καποια φιλτρα προκειμενου να απαλλαξουμε τους routers μας απο ανεπιθυμιτα routes και γενικοτερα να εχουμε ενα πιο καθαρο routing table προς οφελος του δικτιου.

Τα φιλτρα ειναι τα παρακατω:
/routing filter
add action=accept chain=pwmn-bgp-in disabled=no invert-match=no prefix=10.0.0.0/15 prefix-length=32
add action=accept chain=pwmn-bgp-out disabled=no invert-match=no prefix=10.0.0.0/15 prefix-length=32
add action=discard bgp-as-path-length=20-600 chain=pwmn-bgp-in disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=9-24
add action=discard bgp-as-path-length=20-600 chain=pwmn-bgp-out disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=9-24
add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=0-32
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=0-32
add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=0-32
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=0-32
add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=25-32
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=25-32
add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=0.0.0.0 prefix-length=0
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=0.0.0.0 prefix-length=0

τα κανουμε copy ανοιγουμε new terminal μετα paste και enter.
Kατοπιν πηγαινουμε στο bgp καρτελα peers και τα ενεργοποιουμε για καθε peer χωριστα στις επιλογες in filter και out filter πατωντας στο τελος apply.
Τα εχω ηδει περασει στους δυο κομβους μου και φαινονται να δουλευουν κανονικα κοβοντας αρκετη απο τη σαβουρα που κυκλοφορει.
Last edited by freelan on Fri Jul 20, 2012 1:45 pm, edited 1 time in total.
Η Υπερηφάνεια Δεν Θέλει Να Χρωστάει Και Ο Εγωισμός Δεν Θέλει Να Πληρώνει - Φρανσουά Ντε Λα Ροσφουκό -

User avatar
neoplan
Pentium IV
Posts: 1058
Joined: Mon Oct 08, 2007 10:55 pm
PWMN Wind ID: 188

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by neoplan »

Αν μπορείς λίγο να επεξηγήσεις τα παρακάτω
1. Τι κάνει αυτό?

Code: Select all

add action=accept chain=pwmn-bgp-in disabled=no invert-match=no prefix=10.0.0.0/15 prefix-length=32
add action=accept chain=pwmn-bgp-out disabled=no invert-match=no prefix=10.0.0.0/15 prefix-length=32
2. Αυτό μάλλον κόβει ότι έχει as-path πάνω από 20. Αν είναι έτσι τότε δε θα βγαίνουμε ούτε mswn ούτε awmn

Code: Select all

add action=discard bgp-as-path-length=20-600 chain=pwmn-bgp-in disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=9-24
add action=discard bgp-as-path-length=20-600 chain=pwmn-bgp-out disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=9-24
3. Αυτό χρειάζεται γιατί όντως κάποιος το ανακοινώνει αυτή τη στιγμή. Βέβαια θα μπορούσε να το κόψει ο ένοχος ο οποίος είναι με AS: 49001 (ακούς τόλια?????????????)

Code: Select all

add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=0-32
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=0-32
4. Το αντίστοιχο με το 172.16.0.0./12 δεν βρίσκω λόγο να το βάλουμε μιας και δεν υπάρχει αυτό το route σε εμάς

5. Αυτό μπορεί και να χρειάζεται γιατί κάποιοι έχουν ιδιαίτερο setup. Βέβαια αυτά τα μικρά subnet με σωστή ρύθμιση μπορούν να μην ανακοινώνονται καν.

Code: Select all

add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=25-32
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=25-32
6. Αυτό και πάλι δεν το ανακοινώνει κανείς

Code: Select all

add action=discard chain=pwmn-bgp-in disabled=no invert-match=no prefix=0.0.0.0 prefix-length=0
add action=discard chain=pwmn-bgp-out disabled=no invert-match=no prefix=0.0.0.0 prefix-length=0
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn

User avatar
freelan
386
Posts: 195
Joined: Fri Jan 30, 2009 9:25 pm
PWMN Wind ID: 447

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by freelan »

Να ξεκαθαρισω οτι τα φιλτρα αυτα δεν ειναι δικη μου επινοηση.
Χρησιμοποιούνται εδω και πολυ καιρο σχεδον απο το συνολο των κομβων στο awmn και σε συνδιασμο με το MT routing των εκδοσεων 5.xx αντικαθιστα πλεον την guagga.
Εχουν μπει και σε παλαιοτερα λειτουργικα και ειναι ΟΚ.
Τωρα οσον αφορα τις παρατηρήσεις σου να πω οτι μεχρι προτεινος που η ασυρματη ζευξη awmn - pwmn ηταν ΟΚ δεν ειχα παρατηρησει καποια ασυμβατοτητα επικοινωνίας μεταξυ των κοινοτητων και απο τις δυο πλευρες.
Εκει που εστιαζεις φαινεται να εχεις καποιο δικαιο.
Σιγουρα αν κατι δεν ταιριαζει με τις ιδιαιτερότητες του pwmn μπορει να αλλαξει και αυτος ειναι και ο λογος που το συζηταμε.
Εξαλλου οποιος τα δοκιμασει και δει κατι παραξενο μπορει να τα αφαίρεσει εφοσον δημιουργειται καποιο προβλημα.
Η Υπερηφάνεια Δεν Θέλει Να Χρωστάει Και Ο Εγωισμός Δεν Θέλει Να Πληρώνει - Φρανσουά Ντε Λα Ροσφουκό -

User avatar
neoplan
Pentium IV
Posts: 1058
Joined: Mon Oct 08, 2007 10:55 pm
PWMN Wind ID: 188

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by neoplan »

Προς το παρόν δε χρειαζόμαστε φίλτρα γιατί δεν έχουμε σαβούρα στα routes.
Μπορεί με κάποιο φίλτρο να καθαρίζει το τοπίο αλλά στην πραγματικότητα δεν εξαφανίζει το πρόβλημα αλλά το καλύπτει. Άσε που μπορεί να δημιουργήσει πρόβλημα εκεί που δεν υπάρχει (πχ για AS-path > 20)
Εγώ λέω να έχουμε το νου μας στη route-list και αν παρατηρήσουμε κάτι παράξενο να επικοινωνήσουμε με τον κομβούχο και να το λύσουμε.

Τολια ακούς??????
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn

User avatar
grigoris
AMD Athlon
Posts: 951
Joined: Mon Mar 12, 2007 12:25 pm
PWMN Wind ID: 74
Contact:

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by grigoris »

freelan εχεις δικιο, αλλα τα πραγματα πρεπει να γινουν με μια σειρα.
Ακομη δεν εχουμε τελειωσει με το σεταρισμα των AS...

ps. neoplan το "τολια ακους" και το "ακους τολια" δεν επιασε.. βρες κατι αλλο!

User avatar
neoplan
Pentium IV
Posts: 1058
Joined: Mon Oct 08, 2007 10:55 pm
PWMN Wind ID: 188

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by neoplan »

Ακους ρε τόλια???
Old Services by neoplan: http://proxy.pwmn || http://services.pwmn || http://clips.pwmn
http://movies.pwmn || http://dude.pwmn || http://hotspot.pwmn
other services: fakebook.pwmn, dc.pwmn, irc.pwmn, ntp.pwmn

tolias
IBM 701
Posts: 14
Joined: Wed Jul 28, 2010 3:23 am
PWMN Wind ID: 0

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by tolias »

όπως είπα και του neoplan δεν υπάρχει τέτοια διαφήμιση. απλά κάπου έμεινε και έκοβε βόλτες μετά από κάτι πειράματα που έκανα στο 49001. ήδη εξατμίστηκε. Όσο για τα as μέχρι τέλος αυγούστου έρχονται μεγάλες αλλαγές και επεκτάσεις....αναμονή

User avatar
freelan
386
Posts: 195
Joined: Fri Jan 30, 2009 9:25 pm
PWMN Wind ID: 447

Re: Αλλαγή του πρωτοκόλλου δρομολόγησης σε BGP

Post by freelan »

Δεν μας δινεις και μια ιδεα για το τι να περιμενουμε!!!!
BTW στους δυο κομβους στο τρικορφο τα φιλτρα παιζουν κανονικα χωρις να φαινεται κατι περιεργο αφου μπαινω κανονονικα στο awmn αλλα και αντιστροφα απο το awmn στο pwmn, μιλαω στο voip κανω και δεχομαι κλησεις ολα οκ.

Αν καποιος παρατηρησει κατι με το routing ας το γραψει εδω προς ενημερωση.(Φωτη αυτο με το ΑS >20 δεν βλεπω κατι να κοβει γραψε λιγο τι εννοεις οτι κανει).

Αληθεια με τα AS 200-300 τι εγινε εναρμονιστηκαν ή ακομη.Αν χρειαζεται καποια βοηθεια ας τη ζητησουν οι κομβουχοι να γινει και αυτο.
Η Υπερηφάνεια Δεν Θέλει Να Χρωστάει Και Ο Εγωισμός Δεν Θέλει Να Πληρώνει - Φρανσουά Ντε Λα Ροσφουκό -

Post Reply