madwifi in bridge mode

Συζήτηση γύρω από θέματα λογισμικού
Post Reply
mp
AMD Athlon
Posts: 813
Joined: Sat Mar 10, 2007 12:51 pm
PWMN Wind ID: 320

madwifi in bridge mode

Post by mp » Fri Sep 19, 2008 10:47 am

Χρησιμοποιώ σε ένα linux router (alix board) που έχω για μέσα στο σπίτι, τους madwifi σε bridge mode με την ethernet. Έστι οι wireless clients και οι wired clients του δικτύου είναι όλοι στο ίδιο subnet. Το πρόβλημά μου είναι πως ενώ στην αρχή (μετά το boot πχ) δουλεύουν όλα καλά, μετά από 4-5 μέρες οι wired clients δεν κάνουν ping τους wireless και το ανάποδο, ενώ μέσα από τον router φαίνονται όλοι σωστά. Το πρόβλημα διορθώνεται αν βγάλω το madwifi interface από το bridge, το κάνω destroy, το κάνω και πάλι create και το ξαναπροσθέσω στο bridge.

Ξέρει κανείς γιατί μπορεί να συμβαίνει η παραπάνω συμπεριφορά; Είναι buggy η υλοποίηση bridge των madwifi;

mp

User avatar
cornilios
Pentium
Posts: 469
Joined: Sat Mar 10, 2007 6:23 pm

Re: madwifi in bridge mode

Post by cornilios » Fri Sep 19, 2008 11:05 am

να πω μια μαλακια?
μηπως εχεις τσεκαρισμενη καποια λειτουργια που να τους κοβει μετα απο 4-5 μερες? :P
ΑΥΤΟΙ ΠΟΥ ΚΑΝΟΥΝ ΠΩΣ ΞΕΡΟΥΝ ΤΑ ΠΑΝΤΑ ΕΚΝΕΥΡΙΖΟΥΝ ΕΜΑΣ ΠΟΥ ΤΑ
ΞΕΡΟΥΜΕ.

User avatar
sf1n4k1
Pentium IV
Posts: 2046
Joined: Thu Mar 08, 2007 9:11 am
PWMN Wind ID: 95
Location: Rio

Re: madwifi in bridge mode

Post by sf1n4k1 » Fri Sep 19, 2008 11:07 am

Σα bug μυρίζει..που είναι και το πιο λογικό σε madwifi.. (Δε ξεχνιέται το pyrap να παίζει με madwifi...τραγική εμπειρία)

User avatar
Itmy
AMD Athlon
Posts: 883
Joined: Thu Mar 08, 2007 12:17 am
PWMN Wind ID: 108
Location: Itmy Territory
Contact:

Re: madwifi in bridge mode

Post by Itmy » Sat Sep 20, 2008 3:04 pm

mp, Το bridge το συγκεκριμένο (wireless και ethernet) που το είχα δοκιμάσει πριν από 2 χρόνια δεν έπαιζε με τίποτα- οι του ethernet δεν επικοινωνούσαν με τους wireless και το αντίστροφο. Εκτός από bridge στα 2 interfaces και ανάθεση ip στο br0 τι άλλο έκανες?
Death to all Fanatics

mp
AMD Athlon
Posts: 813
Joined: Sat Mar 10, 2007 12:51 pm
PWMN Wind ID: 320

Re: madwifi in bridge mode

Post by mp » Sat Sep 20, 2008 5:16 pm

ifconfig eth0 up
ifconfig ath0 up
brctl addbr br0
brctl addif br0 eth0
brctl addif br0 ath0
ifconfig br0 up
(kai ips ktl meta)

profanos prin dio xronia den epaize kan, tora paizei alla kati pathainei meta apo 2-3 meres.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests